【GPLT】L1-058 6翻了
题目描述:
“666”是一种网络用语,大概是表示某人很厉害、我们很佩服的意思。最近又衍生出另一个数字“9”,意思是“6翻了”,实在太厉害的意思。如果你以为这就是厉害的最高境界,那就错啦 —— 目前的最高境界是数字“27”,因为这是 3 个 “9”!
本题就请你编写程序,将那些过时的、只会用一连串“6666……6”表达仰慕的句子,翻译成最新的高级表达。
输入描述:
输入在一行中给出一句话,即一个非空字符串,由不超过 1000 个英文字母、数字和空格组成,以回车结束。
输出描述:
从左到右扫描输入的句子:如果句子中有超过 3 个连续的 6,则将这串连续的 6 替换成 9;但如果有超过 9 个连续的 6,则将这串连续的 6 替换成 27。其他内容不受影响,原样输出。
输入样例:
it is so 666 really 6666 what else can I say 6666666666
输出样例:
it is so 666 really 9 what else can I say 27
解题思路:
第四届cccc字符串大赛,Python直接一行代码无脑AC,可惜不准用python写啊,然而FOX说C++也可以这样写。先把字符串中9个6以上的”6串”换成”27″,然后再在这个基础上将3个6以上的”6串”换成”9″。
PyAC代码:
import re
print(re.sub('6666+','9',re.sub('6'*9+'6+','27',input())))
CppAC代码(regex求解):
#include <bits/stdc++.h>
using namespace std;
int main()
{
string str;
getline(cin,str);
cout << regex_replace(regex_replace(str,regex("6666666666+"),"27"),regex("6666+"),"9");
return 0;
}
CppAC代码(常规解法):
#include <bits/stdc++.h>
using namespace std;
int main()
{
ios::sync_with_stdio(false);
cin.tie(0),cout.tie(0);
string str;
getline(cin,str);
for(int i = 0; i < str.length(); i++)
{
int cnt = 0;
if(str[i] == '6')
{
int j = i, cnt = 0; //cnt记录连续6的个数
while(str[j]=='6')
{
j++;
cnt++;
}
if(cnt>3 && cnt<=9)
{
str.replace(i,cnt,"9");
}
else if(cnt > 9)
{
str.replace(i,cnt,"27");
}
}
}
cout << str << endl;
return 0;
}
原文链接:【GPLT】L1-058 6翻了
麦芽雪冷萃 版权所有,转载请注明出处。
还没有任何评论,你来说两句吧!