【PAT甲级】The Black Hole of Numbers

正文索引 [隐藏]

Problem Description:

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 — the black hole of 4-digit numbers. This number is named Kaprekar Constant.
For example, start from 6767, we’ll get:
7766 – 6677 = 1089
9810 – 0189 = 9621
9621 – 1269 = 8352
8532 – 2358 = 6174
7641 – 1467 = 6174
… …
Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range (0,10​4​​).

Output Specification:

If all the 4 digits of N are the same, print in one line the equation N – N = 0000. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:

6767

Sample Output 1:

7766 – 6677 = 1089
9810 – 0189 = 9621
9621 – 1269 = 8352
8532 – 2358 = 6174

Sample Input 2:

2222

Sample Output 2:

2222 – 2222 = 0000

解题思路:

这道题跟【PAT乙级】数字黑洞【蓝桥杯】ADV-170 数字黑洞类似。先将输入的那个四位整数拆成4个数字放入一个数组中,然后用这4个数字升序排列、降序排列分别组成最小的数字和最大的数字,用大数减去小数可以得到一个新的数字 输出这个计算式,直到结果是6174或者0时为止。

AC代码:

#include <bits/stdc++.h>
using namespace std;
int arr2num(int a[])   //把数组里的数按照下标次序来组成一个新的数字
{
    int n = 0;
    for(int i = 0; i < 4; i++)
    {
        n = n*10 + a[i];
    }
    return n;
}
int main()
{
    int n;
    cin >> n;
    int a[4];
    do{
        for(int i = 0; i < 4; i++)   //把各位数存入数组里面
        {
            a[i] = n%10;
            n /= 10;
        }
        sort(a,a+4);    //升序排列
        int x = arr2num(a);     //得到由数组a中元素组成的最大数字
        sort(a,a+4,greater<int>());   //降序排列
        int y = arr2num(a);     //得到由数组a中元素组成的最小数字
        n = y-x;    //作差得到一个新的四位数
        printf("%04d - %04d = %04d\n",y,x,n);
    }while(n!=0 && n!=6174);
    return 0;
}