【GPLT】L2-011 玩转二叉树
题目描述:
给定一棵二叉树的中序遍历和前序遍历,请你先将树做个镜面反转,再输出反转后的层序遍历的序列。所谓镜面反转,是指将所有非叶结点的左右孩子对换。这里假设键值都是互不相等的正整数。
输入描述:
输入第一行给出一个正整数 N(N≤30),是二叉树中结点的个数。第二行给出其中序遍历序列。第三行给出其前序遍历序列。数字间以空格分隔。
输出描述:
在一行中输出该树反转后的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。
输入样例:
7
1 2 3 4 5 6 7
4 1 3 2 6 5 7
输出样例:
4 6 1 7 5 3 2
解题思路:
建立三个vector,先序遍历pre、中序遍历in、层序遍历level(level初始化为-1,-1表示此处没有结点)。自定义函数levelorder()的作用是根据先序和中序得到层序遍历,四个参数:root表示先序遍历的根节点,index表示当前的根结点在二叉树的层序遍历中所对应的下标(从0开始)。寻找根结点root在中序遍历中的位置i以区分左右子树的位置。镜面反转时只需改变index的值,左孩子改为2*index + 2,右孩子改为2*index + 1即可。参考了柳神的代码,柳神链接:L2-011. 玩转二叉树-PAT团体程序设计天梯赛GPLT。
AC代码:
#include <bits/stdc++.h>
using namespace std;
vector<int> pre,in,level(1e5,-1);
void levelorder(int root,int start,int end,int index)
{
if(start > end) return ;
int i = start;
while(i < end && in[i] != pre[root]) i++;
level[index] = pre[root];
//镜面反转只需改变index的值,左孩子为2*index + 2,右孩子为2*index + 1
levelorder(root + 1, start, i - 1, 2 * index + 2);
levelorder(root + 1 + i - start, i + 1, end, 2 * index + 1);
}
int main()
{
int N; //二叉树中结点的个数
cin >> N;
pre.resize(N); //修改pre的大小
in.resize(N); //修改in的大小
//输入中序遍历
for (int i = 0; i < N; i++)
{
cin >> in[i];
}
//输入先序遍历
for (int i = 0; i < N; i++)
{
cin >> pre[i];
}
levelorder(0, 0, N-1, 0); //层序遍历
bool isVirgin = true; //判断是不是第一次
for (int i = 0; i < level.size(); i++)
{
if(level[i]!=-1)
{
if(isVirgin)
{
cout << level[i];
isVirgin = false;
}
else
{
cout << " " << level[i];
}
}
}
return 0;
}
原文链接:【GPLT】L2-011 玩转二叉树
麦芽雪冷萃 版权所有,转载请注明出处。
还没有任何评论,你来说两句吧!