【PAT乙级】检查密码
题目描述:
本题要求你帮助某网站的用户注册模块写一个密码合法性检查的小功能。该网站要求用户设置的密码必须由不少于6个字符组成,并且只能有英文字母、数字和小数点 .
,还必须既有字母也有数字。
输入描述:
输入第一行给出一个正整数 N(≤ 100),随后 N 行,每行给出一个用户设置的密码,为不超过 80 个字符的非空字符串,以回车结束。
输出描述:
对每个用户的密码,在一行中输出系统反馈信息,分以下5种:
- 如果密码合法,输出
Your password is wan mei.
; - 如果密码太短,不论合法与否,都输出
Your password is tai duan le.
; - 如果密码长度合法,但存在不合法字符,则输出
Your password is tai luan le.
; - 如果密码长度合法,但只有字母没有数字,则输出
Your password needs shu zi.
; - 如果密码长度合法,但只有数字没有字母,则输出
Your password needs zi mu.
。
输入样例:
5
123s
zheshi.wodepw
1234.5678
WanMei23333
pass*word.6
输出样例:
Your password is tai duan le.
Your password needs shu zi.
Your password needs zi mu.
Your password is wan mei.
Your password is tai luan le.
解题思路:
水题。
AC代码:
#include <bits/stdc++.h>
using namespace std;
int main()
{
int N;
cin >> N;
getchar();
while(N--)
{
string temp;
getline(cin,temp);
int len = temp.length();
if(len < 6) //如果密码少于6位,输出太短了
{
cout << "Your password is tai duan le." << endl;
}
else //如果密码长度合法
{
int zm = 0, sz = 0, dot = 0, qt = 0; //分别记录字母、数字、点和其他字符的个数
for(int i = 0;i < len;i++)
{
if((temp[i]>='a'&&temp[i]<='z')||(temp[i]>='A'&&temp[i]<='Z')) //判断是否为字母
{
zm++;
}
else if(temp[i]>='0'&&temp[i]<='9') //判断是否为数字
{
sz++;
}
else if(temp[i] == '.') //判断是否有小数点
{
dot++;
}
else //不是字母数字小数点就是其他字符了
{
qt++;
}
}
if(qt) //若其他字符的个数不为0
{
cout << "Your password is tai luan le." << endl;
}
else if(sz==0) //若没有数字字符
{
cout << "Your password needs shu zi." << endl;
}
else if(zm==0) //若没有字母字符
{
cout << "Your password needs zi mu." << endl;
}
else //完美
{
cout << "Your password is wan mei." << endl;
}
}
}
return 0;
}
原文链接:【PAT乙级】检查密码
麦芽雪冷萃 版权所有,转载请注明出处。
还没有任何评论,你来说两句吧!